Wednesday, August 22, 2007

Picture library and unsafe updates?!

In addition to my other post about the infamous message from SharePoint: "Updates are currently disallowed on GET requests.  To allow updates on a GET, set the 'AllowUnsafeUpdates' property on SPWeb."  I came across this error in a rather unusual place and that's the one where you click on a picture in a picture library to show the complete image in the browser.

This occurs if you have the following configuration :

IIS : Virtual server  is running in SSL and basic authentication
SharePoint : made a change to the web.config to enable blobcaching (as you can read here to improve the performance of your environment)

When I accessed the environment using Windows Integrated security I did not receive an error. The same applies when I used basic authentication and disabled the blobcache.

Hope this helps someone!

 

Technorati tags: ,

3 comments:

sandeep said...

Thanks Robin. It was helpful.
i have a similar case. I have three servers in farm. i have same issues on 2, i commted the blob cache entry and it started working.
Question 1: i have entry on third server as well then why its working there.

Question 2: I hae one more issue that might have some related to this issue. When i hit the infected servers. i at times i face "The resource cannot be found" error. In addition to this CSS file does not get loaded on these servers so shatters the look and feel.
Does something got deleted from these servers?

Any thoughts??


Thanks

TomK said...

Even easier, and stranger solution :-P

Enable and disable Publishing Infrastructure Site Collection feature.

Hope this helps.

Anonymous said...

Disable/Enable Publishing feature on the site collection worked for me


Thanks a lot !